BESCHREIBUNG
Beim Starten des Desktop-Client der TimeSafe Leistungserfassung tritt beim Aufbau der Datenbankverbindung durch ein Timeout auf und es wird folgende Exception angezeigt:
Telerik.OpenAccess.RT.sql.SQLException: Das Timeout für Sperranforderung wurde überschritten.
Der Desktop-Client schliesst wieder und kann nicht weiter verwendet werden.
URSACHE
Die Datenbank der TimeSafe Leistungserfassung wird blockiert, es kann keine weitere Verbindung aufgebaut werden.
Vermutete Ursachen:
- Zu viele Benutzer sind auf einer SQL Server Express Installation auf der Datenbank tätig.
- Ein laufender Prozess blockiert die Datenbank
- …
LÖSUNG
Im Aktivitätsmonitor des Datenbankservers oder auf der Konsole prüfen, ob eine der möglichen vermuteten Ursachen zutrifft. Allenfalls den betreffenden blockierenden Prozess abschiessen oder schlimmstenfalls den MS SQL Server-Dienst neu starten.