BESCHREIBUNG
Ändert man im Active Directory sowie in TimeSafe den Loginnamen eines Benutzers bspw. von „Domäne\Hans“ auf „Domäne\Fritz“, funktioniert die automatische Anmeldung auf den Web-Client von TimeSafe (siehe KB0428) unter Umständen nicht mehr.
Gibt man die Umgebungsvariablen auf dem Server aus, stellt sich heraus, dass der Benutzer weiterhin als „Domäne\Hans“ am Webserver authentifiziert wird:
AUTH_USER = Domäne\Hans
LOGON_USER = Domäne\Fritz
URSACHE
Auf dem Webserver werden Windows-Anmeldeinformationen in einem Cache gespeichert. Eine Änderung des Logins im Active Directory wird nicht vom Domänencontroller auf im Netzwerk beteiligte Server synchronisiert.
Der Webserver erkennt denselben Benutzer folglich noch unter seinem alten Login, auch wenn in TimeSafe der Login angepasst wurde.
LÖSUNG
Setzen Sie den Cache, welcher die Windows-Anmeldeinformationen speichert, auf dem Webserver zurück. Dies geschieht über die Anpassung der Windows-Registry gemäss folgender Anleitung:
- Öffnen Sie den Registry-Editor über „regedit“
- Navigieren Sie zu folgendem Schlüssel HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
- Fügen Sie einen neuen DWORD-Wert mit Bezeichnung LsaLookupCacheMaxSize ein.
- Ändern Sie den Wert von LsaLookupCacheMaxSize auf 0 und bestätigen Sie die Änderung mit OK.
Anschliessend sollte die automatische Anmeldung auf dem TimeSafe Web-Client mit dem geänderten Login wieder funktionieren.
Quellen: