Home — Leistungserfassung — KB0515: Speichern von Änderungen in der Datenbank nach Windows-Update KB3162659 nicht mehr möglich

KB0515: Speichern von Änderungen in der Datenbank nach Windows-Update KB3162659 nicht mehr möglich

BESCHREIBUNG

Nach Installation des kumulativen Updates KB3162659 für den SQL Server 2014 SP1 können keine Änderungen an den Daten in der TimeSafe Leistungserfassung mehr gespeichert werden.

Es erscheint die folgende (wenig aussagekräftige) Fehlermeldung:

„Infotech.ORM.ORMException wurde ausgelöst:
Failed to retrieve the automatically incremented column value from the server.

Possible reason: A trigger does not perform ’select ID from inserted‘ as last operation.“

Das gleiche Problem kann auch mit einem kumulativen Update für den SQL Server 2012 auftreten.

Das gleiche Problem kann auch mit dem Hotfix 5511 für den SQL Server 2014 mit SP2 auftreten.

Das Problem kann bis und mit Version 16.2.1 der TimeSafe Leistungserfassung auftreten.

URSACHE

Die Installation des Windows-Update „Cumulative Update 7 for SQL Server 2014 SP1“ KB3162659 führt zu diesem Fehler.

LÖSUNG

Es gibt mehrere Lösungen:

  1. Installieren Sie die TimeSafe Leistungserfassung Version 16.2.2 oder höher
  2. Installieren Sie den nächst höheren Service Pack des entsprechenden SQL Servers (empfohlen)
  3. Deinstallieren Sie das entsprechende Windows-Update z.B.: „Cumulative Update 7 for SQL Server 2014 SP1“ (KB3162659).