HomeKB0560: Verbindung zur Datenbank nicht möglich – Timeout aufgetreten (Handshake)

KB0560: Verbindung zur Datenbank nicht möglich – Timeout aufgetreten (Handshake)

BESCHREIBUNG

Beim Starten eines TimeSafe-Clients, welcher auf eine Datenbank auf einem Server zugreift, erscheint nach einiger Zeit eine Meldung in der folgenden Form:

Verbindungsaufbau abgelaufen. Das Timeout ist aufgetreten, während die Bestätigung des Handshakes vor der Anmeldung verarbeitet wurde. Möglicherweise ist ein Fehler beim Handshake vor der Anmeldung aufgetreten, oder der Server hat nicht rechtzeitig geantwortet. Folgende Verbindungszeiten wurden bei dem Versuch benötigt, eine Verinbindung mit diesem Server herzustellen: [Vor Anmeldung] Initialisierung=12; Handshake=14994

Ein Zugriff auf die Datenbank via udl-Datei ist ohne Probleme möglich.

URSACHE

Eine mögliche Ursache ist eine Umgebung mit verschiedenen Subnetzen (Subnetting), sowie Anpassungen im .NET-Framework welche zu einem Timeout führen können.

LÖSUNG

Prüfen Sie zuerst den Artikel KB0024.

Falls dies keine Lösung ist, suchen Sie auf dem Client die Datenbankverbindungsdatei. Dies ist eine Datei mit den Namen in der Form TimeSafeLeistungsserfassungDbVerinbungXXX.config bzw. TimeSafeZeiterfassung.config.

Öffnen Sie die Datei in einem Editor und fügen Sie folgenden Eintrag zum ConnectionString hinzu: ;TransparentNetworkIPResolution=False

Der ConnectionString in der config-Datei kann z.B. wie folgt aussehen:

<ConnectionString>server=SERVER\INSTANZ;database=TimeSafeLeistungserfassung;connect timeout=5;persist security info=True;user id=TimeSafe_usr;password="uAr+EDa1Gr/xHqfrrkZ7i8Qzvq9sCgAac0ab/pJajXQ=";integrated security=False;TransparentNetworkIPResolution=False;application name="TimeSafe Leistungserfassung"</ConnectionString>