Home — Leistungserfassung — KB0585: Fehlermeldung „Der Wert darf nicht NULL sein“ beim Starten

KB0585: Fehlermeldung „Der Wert darf nicht NULL sein“ beim Starten

BESCHREIBUNG
Nach dem Update der TimeSafe Leistungserfassung von einer Version >= 20.0.0 tritt beim Starten folgende Fehlermeldung auf:
Der Wert darf nicht NULL sein.
Parametername: type()

URSACHE
Die edmx-Datei, in welcher das Schema der Datenbank gespeichert wird, wurde nicht ersetzt.

 LÖSUNG
Die Datei Infotech.TimeSafeLeistungserfassung.Daten.TSLDB.edmx muss im Installationsordner der TimeSafe Leistungserfassung gelöscht werden. Danach muss die TimeSafe Leistungserfassung neu gestartet werden.
Der Installationsordner ist bei einer lokalen Installation in der Regel
C:\Program Files (x86)\TimeSafe Leistungserfassung
.

Bei der Verwendung von InfotechStart befindet sich der Installationsordner in
%LOCALAPPDATA%\Infotech_XXXXXXXXX_TimeSafeLeistungserfassung